연구실에 딥러닝 연구를 위한 멀티 GPU 장착 서버가 일곱대있다(더 있남??).

 

평소 안쓰던 놈에 텐서플로우 2 설치하고 텐서플로우 데이터셋(TensorFlow Datasets) 으로 데이터 불러오는데, 이놈의 주피터가 저런 에러를 뱉는다. 에러 메시지가 ipywidgets 을 업그레이드 하라는 것인데, 이 에러메시지와 함께 뜨는 웹사이트(ipywidgets.readthedocs.io/en/stable/user_install.html)에 들어가보면 업그레이드 명령어를 알 수 있다.

 

pip을 쓰면,

pip install ipywidgets

jupyter nbextension enable --py widgetsnbextension

 

conda를 쓰면

conda install -c conda-forge ipywidgets

 

주피터를 사용하고 있는 중이면, 업그레이드 후 커널 재시작을 해주면 끝

Posted by 도전하는 공돌이pooh

댓글을 달아 주세요